督军
PW moblie内测组
PW moblie内测组
  • 发帖数673
  • 铜币450两
  • 威望-74点
  • 贡献0点
  • 注册日期2006-09-03
  • 最后登录2017-04-14
  • 社区居民
阅读:488回复:10

[求助]8.7gbk升级到9.0utf8(0107)版本的奇怪问题

楼主#
更多 发布于:2017-04-04 00:09
先说说我的升级步骤:
原来使用正常的8.7gbk版本(分过一个回复表,后来删除了),其他都正常运行好几年了,
先下载了一个9.0utf8(0107)版本,上传到空间根目录,原来的8.7gbk版本文件全部转移到一个新设的文件夹backup下,
下载了up87to90ForUtf8[13.1.17],运行up87to90.php,一步步升级直到最后提示成功,
初步测试发帖回帖等等功能都正常,在phpmyadmin里查看排序规则是Utf8,
我是从gbk升级到Utf8的,跨版本、跨编码,为什么没出问题?或者还是问题出在哪了?
最关键的是会有什么问题?谢谢高手告知一二,谢谢!
喜欢0 评分0
哆嗦
六星会员
六星会员
  • 发帖数19612
  • 铜币387两
  • 威望2936点
  • 贡献2点
  • 注册日期2006-07-24
  • 最后登录2017-04-25
沙发#
发布于:2017-04-04 11:25
这个不对,先把gbk 8.7转utf8 8.7,然后升级9.0
回复(0) 喜欢(0)     评分
督军
PW moblie内测组
PW moblie内测组
  • 发帖数673
  • 铜币450两
  • 威望-74点
  • 贡献0点
  • 注册日期2006-09-03
  • 最后登录2017-04-14
  • 社区居民
板凳#
发布于:2017-04-04 15:09
我也奇怪,我没有先转码直接升级的,但是能用,不知道为什么
回复(1) 喜欢(0)     评分
265shop
商业版用户
商业版用户
  • 发帖数1519
  • 铜币1387两
  • 威望60点
  • 贡献0点
  • 注册日期2006-10-30
  • 最后登录2017-04-06
3楼#
发布于:2017-04-05 21:37
以前用8.7GBK做站的还有几个在用
回复(1) 喜欢(0)     评分
哆嗦
六星会员
六星会员
  • 发帖数19612
  • 铜币387两
  • 威望2936点
  • 贡献2点
  • 注册日期2006-07-24
  • 最后登录2017-04-25
4楼#
发布于:2017-04-05 23:54
265shop:以前用8.7GBK做站的还有几个在用回到原帖
一直gbk
不用utf8原因
1、不搞ajax插件
2、服务器在内陆,在强大的GFW下,不指望内陆以外的用户访问
回复(0) 喜欢(0)     评分
督军
PW moblie内测组
PW moblie内测组
  • 发帖数673
  • 铜币450两
  • 威望-74点
  • 贡献0点
  • 注册日期2006-09-03
  • 最后登录2017-04-14
  • 社区居民
5楼#
发布于:2017-04-06 17:55
想升级最新版本必须用utf8
回复(0) 喜欢(0)     评分
魅柒
论坛版主
论坛版主
  • 发帖数1766
  • 铜币16948两
  • 威望915点
  • 贡献0点
  • 注册日期2012-07-14
  • 最后登录2017-04-23
  • 社区居民
  • 忠实会员
  • 最爱沙发
  • 社区明星
6楼#
发布于:2017-04-06 20:26
首先,我想确定下你的数据库版本~其次,你是utf-8编码程序读取的gbk数据库,从理论上来说,mysql版本5.3以上的话,也是没有问题的。
回复(1) 喜欢(0)     评分
督军
PW moblie内测组
PW moblie内测组
  • 发帖数673
  • 铜币450两
  • 威望-74点
  • 贡献0点
  • 注册日期2006-09-03
  • 最后登录2017-04-14
  • 社区居民
7楼#
发布于:2017-04-07 01:52
魅柒:首先,我想确定下你的数据库版本~其次,你是utf-8编码程序读取的gbk数据库,从理论上来说,mysql版本5.3以上的话,也是没有问题的。回到原帖
•服务器: Localhost via UNIX socket
•服务器类型: MySQL
•服务器版本: 5.1.73 - Source distribution
•协议版本: 10
•用户: admin@localhost
•服务器字符集: UTF-8 Unicode (utf8)
•nginx/1.4.7
•数据库客户端版本: libmysql - 5.1.73
•PHP 扩展: mysqli
回复(1) 喜欢(0)     评分
魅柒
论坛版主
论坛版主
  • 发帖数1766
  • 铜币16948两
  • 威望915点
  • 贡献0点
  • 注册日期2012-07-14
  • 最后登录2017-04-23
  • 社区居民
  • 忠实会员
  • 最爱沙发
  • 社区明星
8楼#
发布于:2017-04-07 10:52
督军:•服务器: Localhost via UNIX socket
•服务器类型: MySQL
•服务器版本: 5.1.73 - Source distribution
•协议版本: 10
•用户: admin@localhost
•服务器字符...
回到原帖
我是不明白。。。没有问题咋还变成有问题了~感觉该出点问题一样呢~
回复(0) 喜欢(0)     评分
luring
初来乍到
初来乍到
  • 发帖数17
  • 铜币179两
  • 威望0点
  • 贡献0点
  • 注册日期2005-10-31
  • 最后登录2017-04-17
9楼#
发布于:2017-04-17 04:05
督军:我也奇怪,我没有先转码直接升级的,但是能用,不知道为什么回到原帖
回复(0) 喜欢(0)     评分
楓
论坛版主
论坛版主
  • 发帖数25617
  • 铜币11908两
  • 威望12576点
  • 贡献8059点
  • 注册日期2005-12-16
  • 最后登录2017-04-25
  • 资深版主
  • 社区居民
  • 忠实会员
  • 最爱沙发
  • 社区明星
  • 民间侠客
10楼#
发布于:2017-04-17 18:27
这样升级没有问题啊。

你是升级后没出现问题而觉得有问题的节奏吗?
回复(0) 喜欢(0)     评分
游客

返回顶部