月明星稀稀
荣誉会员
荣誉会员
  • 发帖数3285
  • 铜币96123两
  • 威望1983点
  • 贡献99634点
  • 注册日期2014-09-23
  • 最后登录2016-11-09
45楼#
发布于:2015-05-12 11:03
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
enlangs:请楼主          看下,最新的phpwind版本,无法使用这个插件。。回到原帖
怎么了?是测试过的呀
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
46楼#
发布于:2015-05-12 15:46
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
月明星稀稀:怎么了?是测试过的呀回到原帖
我安装PW,然后安装移动api插件,再安装OSS插件。不管是附件、图片、还是头像都无法上传到OSS里面去(OSS里面无内容)。
月明星稀稀
荣誉会员
荣誉会员
  • 发帖数3285
  • 铜币96123两
  • 威望1983点
  • 贡献99634点
  • 注册日期2014-09-23
  • 最后登录2016-11-09
47楼#
发布于:2015-05-12 15:57
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
enlangs:我安装PW,然后安装移动api插件,再安装OSS插件。不管是附件、图片、还是头像都无法上传到OSS里面去(OSS里面无内容)。回到原帖
移动api插件是啥东西?
月明星稀稀
荣誉会员
荣誉会员
  • 发帖数3285
  • 铜币96123两
  • 威望1983点
  • 贡献99634点
  • 注册日期2014-09-23
  • 最后登录2016-11-09
48楼#
发布于:2015-05-12 15:58
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
enlangs:我安装PW,然后安装移动api插件,再安装OSS插件。不管是附件、图片、还是头像都无法上传到OSS里面去(OSS里面无内容)。回到原帖
是移动端的补丁包?
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
49楼#
发布于:2015-05-12 17:49
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
月明星稀稀:是移动端的补丁包?回到原帖
是的。。
ww w.phpwind.net/read/3418959
月明星稀稀
荣誉会员
荣誉会员
  • 发帖数3285
  • 铜币96123两
  • 威望1983点
  • 贡献99634点
  • 注册日期2014-09-23
  • 最后登录2016-11-09
50楼#
发布于:2015-05-12 17:55
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
没装补丁包前是正常的?
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
51楼#
发布于:2015-05-12 19:49
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
月明星稀稀:没装补丁包前是正常的?回到原帖
没有测试过,我是先安装补丁包,然后再安装OSS插件。。
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
52楼#
发布于:2015-05-12 20:11
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
月明星稀稀:没装补丁包前是正常的?回到原帖
刚刚测试了下,如果先安装OSS插件,仍然不行。。

不能上传图片。
月明星稀稀
荣誉会员
荣誉会员
  • 发帖数3285
  • 铜币96123两
  • 威望1983点
  • 贡献99634点
  • 注册日期2014-09-23
  • 最后登录2016-11-09
53楼#
发布于:2015-05-13 10:56
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
那肯定是跟你的设置有关系。参考下这几个帖子:
http://www.phpwind.net/read/3413467
http://www.phpwind.net/read/3415695
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
54楼#
发布于:2015-05-13 11:21
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
经过测试,完整的按照你提供的2个帖子内容,还是不行。不知道你是否测试过。另外,我打算在本地再搭建个测试环境。
月明星稀稀
荣誉会员
荣誉会员
  • 发帖数3285
  • 铜币96123两
  • 威望1983点
  • 贡献99634点
  • 注册日期2014-09-23
  • 最后登录2016-11-09
55楼#
发布于:2015-05-13 11:29
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
enlangs:经过测试,完整的按照你提供的2个帖子内容,还是不行。不知道你是否测试过。另外,我打算在本地再搭建个测试环境。回到原帖
这个是经过测试的,完全没有问题,现在官网用的就是。
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
56楼#
发布于:2015-05-13 11:58
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
/**
 * 上传文件,适合比较大的文件
 * @param string $bucket (Required)
 * @param string $object (Required)
 * @param string $file (Required)
 * @param array $options (Optional)
 * @author xiaobing.meng@alibaba-inc.com
 * @since 2012-02-28
 * @return ResponseCore
 */
public function upload_file_by_file($bucket,$object,$file,$options = NULL){
    //options
    $this->validate_options($options);
 
    if(!$options){
        $options = array();
    }
 
    //bucket
    $this->is_empty($bucket,OSS_BUCKET_IS_NOT_ALLOWED_EMPTY);
 
    //object
    $this->is_empty($object,OSS_OBJECT_IS_NOT_ALLOWED_EMPTY);
 
    //file
    $this->is_empty($file, OSS_FILE_PATH_IS_NOT_ALLOWED_EMPTY);
    if($this->chk_chinese($file)){
        $file = iconv('utf-8','gbk',$file);
    }
 
    $options[self::OSS_FILE_UPLOAD] = $file;
    if(!file_exists($options[self::OSS_FILE_UPLOAD])){
        throw new OSS_Exception($options[self::OSS_FILE_UPLOAD].OSS_FILE_NOT_EXIST);
    }
    $filesize = filesize($options[self::OSS_FILE_UPLOAD]);
    $partsize = 1024 * 1024 ; //默认为 1M
 
    $extension = explode ( '.', $file );
    $extension = array_pop ( $extension );
    $content_type = MimeTypes::get_mimetype(strtolower($extension));
    $options[self::OSS_METHOD] = self::OSS_HTTP_PUT;
    $options[self::OSS_BUCKET] = $bucket;
    $options[self::OSS_OBJECT] = $object;
    $options[self::OSS_CONTENT_TYPE] = $content_type;
    $options[self::OSS_CONTENT_LENGTH] = $filesize;
    $response = $this->auth($options);
     
    return $response;
}
分析发现,这个函数中auth出错。认证不通过!!!
enlangs
初来乍到
初来乍到
  • 发帖数15
  • 铜币191两
  • 威望45点
  • 贡献0点
  • 注册日期2008-03-16
  • 最后登录2015-05-29
  • 社区居民
57楼#
发布于:2015-05-13 12:40
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
问题找到:由于我的bucketName中包含“-”,OSS的SDK里面的校验和OSS官方给的内容不一样。
/**
 * 检验bucket名称是否合法
 * bucket的命名规范:
 * 1. 只能包括小写字母,数字
 * 2. 必须以小写字母或者数字开头
 * 3. 长度必须在3-63字节之间
 * @param string $bucket (Required)
 * @author xiaobing.meng@alibaba-inc.com
 * @since 2011-12-27
 * @return boolean
 */
private function validate_bucket($bucket){
    $pattern = '/^[a-z0-9][a-z0-9]{2,62}$/';
    if (! preg_match ( $pattern, $bucket )) {
        return false;
    }
    return true;
}
官方是:
Bucket命名规范:
» 1. 只能包含小写字母,数字和短横线
» 2. 必须以小写字母和数字开头和结尾
» 3. bucketName的长度限制在3-63之间

不知道怎么回事,你们这儿的描述居然不一致!!!
我去查询了你们最新的OSS的SDK,发现你们最新的SDK没有这个BUG。
/**
 * 检验bucket名称是否合法
 * bucket的命名规范:
 * 1. 只能包括小写字母,数字
 * 2. 必须以小写字母或者数字开头
 * 3. 长度必须在3-63字节之间
 * @param string $bucket (Required)
 * @author xiaobing.meng@alibaba-inc.com
 * @since 2011-12-27
 * @return boolean
 */
private function validate_bucket($bucket){
    $pattern = '/^[a-z0-9][a-z0-9-]{2,62}$/';
    if (! preg_match ( $pattern, $bucket )) {
        return false;
    }
    return true;
}


看他的正则表达式中,明显的包含有“-”。


看样子是 你的这个SDK不是OSS最新的。。


PS:SDK版本不一致是否有其它BUG呢??


烦请管理员注意这个问题。


============
你猜猜好不好
三星会员
三星会员
  • 发帖数409
  • 铜币530两
  • 威望97点
  • 贡献0点
  • 注册日期2015-03-21
  • 最后登录2017-03-12
58楼#
发布于:2015-05-14 10:50
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
月明星稀稀:这个是经过测试的,完全没有问题,现在官网用的就是。回到原帖
青岛,内网传输,安装成功了,但是论坛删除附件,附件还留在OSS里
tianuc
初来乍到
初来乍到
  • 发帖数5
  • 铜币188两
  • 威望0点
  • 贡献0点
  • 注册日期2007-11-15
  • 最后登录2015-06-26
  • 社区居民
59楼#
发布于:2015-06-16 11:52
系统提示:关于phpwind产品的学习与交流已经迁移到阿里云论坛,请访问这里:https://bbs.aliyun.com/fourms.php?m=bbs&cateid=403
建议增加CDN url 功能. 现在都是用 oss自带的地址 很不爽
上一页 下一页
游客

返回顶部